【问题已解决】在 Debian Linux 的 KVM 虚拟机里面的 Windows 10(64-bit)无法使用 geph v4.1.7 的 VPN 模式

我这个是新装的系统,是不是缺什么库?如果是缺库的话,我建议开发者不要用这些库,避免对这些库形成依赖。

1 Like

根据 VCRuntime140.dll - Microsoft Community 的讨论,可能缺少的是 Microsoft Visual C ++ 2015

1 Like

thank you.

1 Like

我已经安装了 Microsoft Visual C++ 2015 这个库,而且也重新启动了系统,而且我还重新安装了 geph,然而还是出现这个弹窗,目前问题没有解决。

也许可以尝试在虚拟机中使用宿主系统的代理。

微软的 VC++ 依赖很坑,许多软件都需要,但有时候自动安装,有时候需要手动下载全部的包,手动安装。简直不要太麻烦 :disappointed_relieved:

那你知不知道,有什么软件可以把 Socks 转换成 VPN?而且必须要有能让特定软件绕过 VPN 的功能,防止 geph 的流量也走 VPN,导致流量无限循环的问题。

或者是,有没有能够自动安装 Microsoft Visual C++ 库的软件?

Socks 转全局并且能编写规则,Mellow 或者 Netch 应该能实现。

Microsoft Visual C++ 完整包似乎安装 vcredist 能够完成。

1 Like

thank you very much.

1 Like

我也收获了很多知识。 :grinning:

1 Like

@Mike_Henry

非常感谢,我的问题已经解决,我安装了 vcredist 2019 的库。

1 Like

我一般不用 Windows,我主要是懒得折腾 Windows。